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KB56847
OptoOPCServer returns erratic tag quality if OPC client refers to data item incorrectly
Revision:  2.0
Published:  4/23/2007
Applies To
OptoOPCServer
Versions
Problem was found in version:  
R7.0a
Problem is fixed in version:  
R8.0c

SYMPTOMS

If a custom OPC client or PAC Display client accesses data from a control engine and the data item does not exist in the control strategy, or the OPC client references a data item name incorrectly, then OptoOPCServer does not handle the information returned by the control engine properly. This could include, but is not limited to requesting a tag that no longer exists, or a table index that is out of range.

As a result, erratic tag quality changes occur in OptoOPCServer.

CAUSE

A component of OptoOPCServer, iolib_engine.dll, does not handle the error returned from the control engine correctly.

RESOLUTION

Opto 22 has resolved this issue.

Relevant Downloads
No relevant downloads have been specified.
Questions? Contact Opto 22 Product Support.
Phone: 800-835-6786 or 951-695-3080
Email: support@opto22.com

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