Opto 22

43044 Business Park Drive, Temecula, CA 92590 USA
Local & outside the USA:(951) 695-3000
Toll-Free within the USA:(800) 321-6786
Fax: (951) 695-3095
Email: sales@opto22.com
 
KB58160
Accessing a NULL pointer may cause a Stack Overflow, Bad Quality data
Revision:  3.0
Published:  12/12/2007
Applies To
Firmware for:
SNAP-PAC-S1
SNAP-PAC-R1
SNAP-PAC-R2
SNAP-UP1-ADS
SNAP-UP1-M64
SNAP-UP1-D64
SNAP-LCE
Versions
Problem was discovered in version:  
R8.0c SNAP PAC control engines
Problem was discovered in version:  
R6.0a Ultimate I/O control engines

Problem is fixed in version:  
R8.1a SNAP PAC control engines
Problem is fixed in version:  
R7.2h Ultimate I/O control engines

SYMPTOMS

If a NULL pointer variable is requested from a control engine strategy by a PAC Display project or an OPC client, a recoverable error, a Stack Overflow error, may occur.

From PAC Control, if the Debugger is open at the time the Stack Overflow error occurs, a "Stack Full" error message appears. Select the Retry button to resume normal operation. If Debugger is not open at the time the error occurs, no other indication of a problem may be apparent.

From a PAC Display project, the Event Log may log that a tag or a group of tag qualities changed to "Bad Quality." At the Opto OPC Scanner level, a "Bad Quality" message may appear for the group of data that caused the Stack Overflow error.

After the Stack Overflow error occurs, the control engine stack is cleared, and the control engine resumes normal operation.

CAUSE

The firmware command used when a PAC Display project or Opto OPC Server client needs a value from the control engine, leaves an item on the control engine stack after accessing a NULL pointer variable.

RESOLUTION

Opto 22 has resolved this issue.

Relevant Downloads
No relevant downloads have been specified.
Questions? Contact Opto 22 Product Support.
Phone: 800-835-6786 or 951-695-3080
Email: support@opto22.com

DISCLAIMER

This Opto 22 Knowledge Base ('OptoKB') article is intended to provide general technical information on a particular subject or subjects and is not an exhaustive treatment of such subjects. Accordingly, the information in this OptoKB article is not intended to constitute application, design, software, or other professional engineering advice or services. Opto 22 may modify the OptoKB articles at any time. Before making any decision or taking any action which might affect your equipment, you should consult a qualified professional.

OPTO 22 DOES NOT WARRANT THE COMPLETENESS, TIMELINESS, OR ACCURACY OF THE DATA CONTAINED IN THIS OPTOKB ARTICLE AND MAY MAKE CHANGES THERETO AT ANY TIME AT ITS SOLE DISCRETION WITHOUT NOTICE. FURTHER, ALL INFORMATION CONVEYED HEREBY IS PROVIDED TO USERS 'AS IS.' IN NO EVENT SHALL OPTO 22 BE LIABLE FOR ANY DAMAGES OF ANY KIND INCLUDING DIRECT, INDIRECT INCIDENTAL, CONSEQUENTIAL, LOSS PROFIT, OR DAMAGE, EVEN IF OPTO 22 HAS BEEN ADVISED ON THE POSSIBILITY OF SUCH DAMAGES.

OPTO 22 DISCLAIMS ALL WARRANTIES WHETHER EXPRESSED OR IMPLIED WITH RESPECT TO THE INFORMATION (INCLUDING HARDWARE, SOFTWARE, AND/OR FIRMWARE) PROVIDED HEREBY, INCLUDING THE IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR PURPOSE, MERCHANTIBILITY, AND NON-INFRINGEMENT. Note that certain jurisdictions do not sanction the exclusion of implied warranties: thus, this disclaimer may not apply to you.

Copyright © 2016 Opto 22. All rights reserved.

My.Opto22

All Opto22

Request Information
  • FREE Product Brochure
  • Product Demonstration
  • PreSales Engineering Assistance

Opto 22 Product Support

Opto 22 Product Support is FREE Monday through Friday 7 a.m. to 5 p.m. Pacific Time

Product Support Numbers:

Local: (951) 695-3080
Toll-Free: (800) 835-6786
Fax: (951) 695-3017
support@opto22.com

Products

None

Downloads

None

Documents

None